Zenith Data Systems 80c88 laptop from circa 1985

Hello all, I have an old Zenith “laptop” that runs on an 80c88 processor, and apparently was manufactured around 1985. It’s quite a beast of a laptop - size and weight, rather than computing power!.

Unfortunately it fails at boot with a Timer Interrupt Error.


I’ve started digging for any info that will help with a fix, with not much to find on the error or generally on the computer itself. The manuals have some basic hardware descriptions, but I’ve not found any schematics or technical fault finding manuals.

If anyone has any hints or tips, your advice would be much appreciated. Also, if there are any other online forums that are better for this kind of question, appreciate the info.

I’ve already posted on a retro computer forum on Facebook, with some good advice for fault finding, however the fix remains elusive, so looking to the experts on this forum for any further advice.

Discussion on Facebook forum


Many thanks
Rob

2 Likes

First, welcome to the forum!

Nice machine! I’m hardly one of the experts, you’re looking for, but, nevertheless, a few remarks on the FB stream:
The “bubbled trace” is typical for the era, this is not a fault, but rather a common technique for adding extra conductivity to ground and power rails by adding a coat of wave solder to them.
It doesn’t seem to be related to the real-time clock, as there’s a dedicated error message for this ("Calendar Failure!, compare the manual, p.17.2). Provided the rather basic information given in the manual, it seems to be related to the interrupt circuitry, at least, it’s were the failure shows in the startup self-tests. With a bit of luck, it’s about one of the socketed support chips and reseating the chips may help. Have you tried this already?

BTW, the manual speaks on p. 17.3 about “disk based diagnostics”, which are allegedly more exhaustive and provide more information than the built-in startup self-tests. Do you have access to them? (According to the manual, there’s also extra documentation coming with the software.)

1 Like

Hello, thanks for the warm welcome!

Indeed, I have tried reseating the socketed chips a few times, I even gave the DIP sockets a good spray with electro cleaner in case that helped. I’ll give these chips another go though. Maybe there’s particular pins I should focus on.

I hadn’t heard about Disk Based Diagnostics. I got no floppy disks with computer, however there is a hard-drive, maybe there’s additional diagnostic software on it?? Problem is that the computer hangs at the Interrupt fault, so I have no means doing anything further with the computer, so I can’t access the hard-drive contents.

Many thanks for your support, I appreciate the advice.
Rob

Just found this page: https://vetusware.com/manufacturer/ZenithMicrosoft/

(Still, there remains the problem of running diagnostic software on a machine that fails to start up… :wink: )

1 Like

That’s brilliant! Once I get the machine working, I’ll need to suss out how to transfer files from the Internet. Perhaps I could get a compatible 3.5" USB floppy drive for my modern PC. Or perhaps a serial cable between old and new with a terminal program?

Thanks again
Rob

I had a brief look at the manual (https://archive.org/details/Z180PCSeriesLaptopComputersOwnersManualZenithDataSystems1987) and I’m actually impressed by the computer and the quality and level of detail of the manual. There’s a quite powerful system monitor in ROM, which also performs the self-test. As this is also the part which is issuing the error message, it seems to be working. (This and that the computer can displays the error message, indicates that most of the sub systems are ok.) You can bypass the normal startup procedure and boot directly into the monitor, which allows you to peek into various configuration and status registers (and even features a built-in disassembler), refer to chapter 8 of the manual.

(The DIP switches seen on the board, AKA “configuration switches” in the manual, which made me curious in the beginning, seem to be ok, set up for one internal floppy disk drive as drive A, 4.77 MHz, 80 chars, internal LCD. Compare section 7 of the manual.)

Given the general quality of the manual, I’d take the section on this error message from the trouble shooting section rather seriously, however vague it may seem:

+++ ERROR: Timer Interrupt failure! +++
This error message indicates the possible failure of interrupt controller and/or the timing logic. If this error message appeared after the system was reassembled, it is possible that the main board was incorrectly mounted during reassembly and is being stressed in such a manner as to cause this problem.

I guess, you may not be the first one to get hands-on with the machine and this may apply to your case. Maybe losen all the screws or even try to run the board out of its case? Otherwise, it may be really an issue with any of the chips and/or their connections. In this case, maybe any of the status/config values which may be retrieved by the system monitor may give a further indication? (At least the section quoted above appears to indicate that there is no other known failure mode for this, other than a flexing board.)

Finally, timing functions may involve capacitors. The machine may be just old enough not to suffer from the notoriously failing surface mount capacitors of the early 1990s, but inspecting any of those related to the timing circuits (if there are any at all) and maybe even sniffing, if there’s anything fishy, may be worth it.

(Here I’m at the end of my quite limited hardware wits.)

As said already, I’m quite impressed by this computer, it seems that Zenith was actually interested in delivering a decent system.

Edit: On second thought, if you’re running the machine without any of the drives attached, maybe configure the DIP switches to “no internal drive” (compare sect. 7 of the manual)? I don’t think that this should cause the error, but you never know…

2 Likes

Welcome Rob! Looks like you might have a few leads to follow now.

On the topic of how to get a program onto the machine, there are ideas in this previous thread:
Communications on Toshiba T1000 laptop

On the topic of where else to ask, maybe try

  • the classiccmp mail lists
  • the forums at vcfed
  • the retrocomputing stackexchange
1 Like

Many thanks for your insights and suggestions. Looks like you found a better manual too, the one that I have in hardcopy is about half the size with half the content.

I have run it with the motherboard out of the case, same error problem appeared. I’m sure that I had read that they had some quality problems in at one point that required aftermarket servicing (relating to the fitting?), I wouldn’t be surprised if this error was one of the issues, however it would be nice if there was a simple technician’s repair instruction from the time - no joy in finding this so far.

It was an excellent call on your part to try and run the onboard Monitor. It did divert to monitor with the multi-key combination at boot up, unfortunately it didn’t work further, every key presses would give an error beep and nothing happened. Good call though, as it has given my another road to go down. (I’ll try and upload the video on to the FB forum, don’t know how to do it here)

I’ve not got to the point of old capacitors yet. It may be coming though.

Thanks again for your support!
Rob

Thanks for the info on comms to old PC’s, here’s hoping that I get that far!

I’ve posted on Stack Exchange for any ideas, I’ll check the others too.

Many thanks for your encouragement.
Rob

1 Like