TRS-80 model 3 problems

When I went to power up a recently acquired TRS-80 Model-3, I found it didn’t work.
It gives me either a trash screen of some sort, or a single dot in the bottom left corner of the screen.
I also cannot seem to find how to play the program cassettes and boot up the computer.
It powers on and the only peripheral I got with it was an external floppy disc reader.
I would really like help with this, and I can be contacted at [email protected].
If I need to ship it, I can pay up to 50 dollars, or drive it over there so long as it is in Washington State, and preferably on the west side of the cascades.
I have pictures of the problem, and nothing appears broken inside of the computer when I took the lid off.

Welcome! In case you don’t get any direct help or advice from members here, a couple of other places to try:

Vintage Computer Federation Tandy/Radio Shack forum

Atari Age forums, Tandy computers

(Both these forums have had Model 3 repair threads in the past, and members there might be able to point you to more resources.)

1 Like

I’ll second Ed’s recommendation of the VCF forums. You may also be able to find local help from someone in the Seattle Retrocomputing Society:

https://www.seattleretrocomputing.com/

I’m just across the border in Vancouver which may as well be a million miles away these days. And I’m no hardware expert but I can suggest a few things to try.

If there is any sort of floppy attached externally or internally you may see nothing on power-up. Hold down the BREAK key while powering on (or when pressing the orange RESET button) and you’ll go into ROM BASIC with it’s classic “Cass?” prompt. You can simply press to that and the “Memory Size?” prompt to get into the BASIC Ready prompt.

If those don’t show up it is often because of mis-adjusted contrast and brightness. Try fiddling the two knobs found under the left edge of the computer. It is pretty common for them to be frozen up after being unused for so long.

Barring that, you can try going into ROM BASIC blind following the procedure above - hold BREAK, press orange reset button, release BREAK, press ENTER twice then wait 2 or 3 seconds. Now type:

CSAVE"A"

and press ENTER. If the machine is working you’ll hear a pretty distinct click of the cassette relay activating.

3 Likes

Hey, I’ve already used the break key, it does have an external floppy but it’s optional storage. I’ve tried putting the TRSDOS floppy in, even putting it in upside-down, but all I get is a single dot. I’ve reseated the ram chips to no effect. I didn’t get it with the cassette or any other peripherals but the extra floppy drive. I have all the program tapes and floppies, as well as the manuals and programming guides, but they’re pretty much useless, seeing as the nearest radio shack store closed like 3 years ago, and they stopped repairing them even longer ago.

If you can fix it, I may be able to ship it to you, or just hand it over near the border in Washington.

Ill check the retrocomputing society

Here are some pictures of whats happening

The brightness and contrast settings work.

Afraid I’m really no use when it comes to fixing machines. I know a fair amount about them but have no experience in repair.

The pattern on the screen isn’t totally random but there could be any number of causes.

There is a fellow in Texas who specializes in TRS-80 repair but even just the shipping is likely to be expensive.

I think the good news is that the power supply is fine and the computer is doing something sensible: I notice the floppy light is on in one photo. So a fair bit of code is running, the CPU and RAM and ROM is at least partly OK.

The next step probably involves some knowledge of common failure modes. Finding an expert to look at it would satisfy that!

I don’t know anything about the TRS-80, specifically, but if I saw that on one of my machines, if suspect a bad row of bits in RAM. If your RAM chips are socketed, try re-seating them. If they’re 4116s, I’d put money on a bad chip.

Good news is, if that’s it, it’s an easy fix.

(Edit: by the way, one reason I think that is that those look like @ signs to me, and ASCII @ has exactly one bit set.)

@elb could be @ s but they’re completely solid I’v already reaseated the RAM to no real effect, I did however find some of the chips where actually chipped (As in material was chipped off). @EdS I hope what you say is true, but it may just be attempting to read them.

@gp2000 Who’s that guy in Texas, I can contact him once I’ve tried everything. I really have about as much experience as you do.

OK, that’s probably not @, then. That may make bad RAM less likely, or it may not; I don’t know enough about the TRS-80 character set. (For example, on some platforms, the “shift bit” or “control bit” — or even the high order bit — causes reverse video.) If you move the RAM chips to different sockets, do the symptoms change?

I’m pretty sure I did when I was reaseating them, I wasn’t too careful to put them in the same slots (I did put them in the same orientation) The symptoms didn’t seem to change. The trash screen is only if I turn it off and back on with out pausing 5 seconds.

However, in the trash screen the character: ñ appears commonly.

If turning it rapidly off and back on causes it but pressing the reset button does not, it’s probably just the way the reset circuitry works, and it’s not getting a clean reset. (In particular, if pressing reset “cleans it up”, this is almost certain.) Someone more familiar with the TRS-80 Model 3 would have to weigh in on that.

I concur with @EdS, the fact that you’re getting as much as you are indicates that the system is almost working, I think you can chase this down and bring it back to life. Some of the TRS-80 and other fora mentioned above may have a list of common failures that will lead you right to the culprit.

The trick is finding the exact circuitry that needs fixing.
I think I’ll just replace all the socketed chips on the same board as the ram.

I think that one reason it isn’t working could be I have no cassette machine hooked up to it

Patrick Bureau – his email address is on the “Contact” page of his web site.

One simple test is the finger test: if one or two of the RAM chips is much hotter than the others, that’s one to try replacing.

2 Likes