IBM P90 730 Model 6875 HELP PLS!

Hi all!

Hope it is ok for me to post here. I bought this pc from Ebay. I want to put an internal 5.25 floppy drive in there but for the life of me cannot get the case open! There are no screws or anything if anyone can help I would be most grateful it is the model where the front panel can slide across to cover the drive bays.

Cheers,

C

Totally ok to pose the question! :slight_smile:

I found this (Czech) auction page, which shows some images of the machine with an open case. Maybe this provides some insight in the construction?
https://aukro.cz/stary-pocitac-ibm-730-p90-funkcni-6992405371

edit: See the image https://f.aukro.cz/images/sk1625253579822/730x548/stary-pocitac-ibm-730-p90-funkcni-103240146.jpeg, there seems to be some Allen key style screw on the center top of the front panel (if this is the same model at all).

HI and thx so much for the reply! I believe the lock is to lock a panel into place that slides across the drive bays. I think it is a sales gimmick that IBM came up with at the time. It seems to be in the unlocked position. The guy I bought the pc from said it never had a key and he opened it up to clean it and put a new hard drive in etc but was a long time back and couldn’t remember exactly how he did it.

Really odd as the on-line manual shows how to replace drives/CPU etc but not how to actually open the case! I will try and post some pics in an hour or so during my break at work.

Again thanks so much for your help!





The top cover looks a bit like it may slide towards the front. Meaning, just lift it gently at the back end and give it a try? (I recall some units working like this, but can’t remember the make or vendor.)

Hi

The top cover doesn’t lift up at all, unfortunately. Not even the slightest bit of give.

The PS/2 line was made to be worked on without tools. So there’s a release somewhere.

The only ideas that I had were

  1. Fiddle with the IBM logos on case to see if those are the releases.
  2. On the back of the case, there’s a plate that seems out of place. It has a “1” marked next to it. Perhaps that’s the case release.

Some other PS/2 models open simply by sliding the top (and side) cover backwards; e.g, https://www.youtube.com/watch?v=S3ygCSMiZog

Some models have lock screws that need to be loosened first (possibly including the PS/2 Model 30 in the link above). See (e.g.) Cracking Open: IBM PS/2 Model-55sx - Page 9 - TechRepublic

1 Like

Hi thx for the reply! I have tried both of those neither work.

Hi thx for the reply!

In fact I have those IBM models no probs at all to open. This one is different. I can find no way to open it.

I have managed to get the rear plastic bezel off… almost broke it. You have to sort of pluck it out and shift it to the left? Who knew. This is what it looks like now but still cannot open it…



I would expect the top cover to slide backwards - so, as noted, there must be some latch or release, perhaps accessible through the holes in the back panel, or perhaps at the front underneath.

It actually looks to me like it might slide forward, as the channels at the bottom of the top cover are open all the way to the rear. I’d certainly start looking underneath for a latch, though.

Hey guys/Eds!

You are quite right I have been such an idiot! There is indeed a tab underneath that let’s releases the case cover and let’s it slide out through the back. But why oh why didn’t IBM state how to do it in the manual!? Anyway I have left a pic thank you all so much for replying so kind I could not have done it without you all thank you all so much! I still have to install the 5.25 floppy


drive I really hope it goes OK and works I bought it new from ebay cost me ÂŁ200 lol hope it works fingers crossed :crossed_fingers:!

2 Likes

Oh yes the tab was indeed on the underside of the front plastic bezel. Again can’t thank you guys enough!

1 Like

great result! (I had found a couple of service manuals and they just said “remove the top cover” which was no help at all. I do like the zero-tooling approach to design.)

1 Like

Congratulations!

You are supposed to call IBM service. Which is why you have this service contract… :wink:

This is like my Honda CMX250C service manual which, for some carb-related activity, simply says “remove the carburetor”. That’s a sufficiently involved process that I made a YouTube video about how to do it without removing the fuel tank. :wink: