Challenge with Epson NB-SL20

#1

Hi everyone! Good morning! I will start with a great challenge soon: I wish repair a laptop Epson NB-SL20 that I have received yesterday. It looks really nice, the problem is that it won’t turn on, the power supply is ok and it don’t have signals of corrosion. Anyone have experience in repairs on this kind of computers?

Any help or comment are welcome ! :smiley:

Manual: https://files.support.epson.com/pdf/nbsl20/nbsl20pg.pdf

1 Like
#2

The usual suspects are electrolytic capacitors… when they degrade they go short circuit. The PSU may be okay to a multimeter, but it may not be able to deliver the current.

The sequence I do is to check the capacitors visually… is there a really funky smell coming from them/deformed or leaking? Disconnect the NiCd battery - its most probably dead and causing the overload protection to trip out.

PSU off load tests…
PSU on load test.

inside the computer… 5V 12V and other rails. (there most probably is a -12V one there)

If there is an external monitor… give it a go.

Richard

1 Like
#3

Good ideas. I’d probably start by checking the power connector: they can get knocked and damaged. Then tracing to see where the power gets to and what voltages it reaches. If there’s any coin cell or similar in there look for leakage and damage from that. Likewise damage from electrolytic capacitors, and any blown tantalums. Or ceramics - I’ve a feeling even ceramic disk caps can fail.

2 Likes
#4

oooooh… forgot those tantalum’s! They make a nice bang and fizzzzzzz when they go. At-least they are not sneaky like the electrolytic one that start lowering their resistance. I have never seen a ceramic cap that has blown, but I have seen the pads corroded away on a surface mount version - only seen that once though.

#5

Any high resolution pictures available? If not, can you take them? My Google-Fu is broken and I cant find any updated web pages with imagery

Richard

1 Like
#6

Hi everyone! Thanks for the comments. I have tried replace the most suspicious capacitors that I have been able to detect, without lucky. I will take some pictures of each board and share them with the group.

About the charger, it have 2 voltages, 9V and 13V. I believe that the last one is used to charge the batteries, but I could’t confirm my theory. The charges seems to be ok, under load and without it the charger maintains both voltages without problems.
The only thing that it’s working is the led “DC/Charge”, but nothing more.

Currently I’m trying to track the line that have the “power on” signal, to check that I’m sending the signal to the power supply board or something it’s broken in the middle.

#7

Keep the battery disconnected, the insides should have a ‘soft start’ function, so the power switch/something has to tell the PSU to ‘Switch On’

Additionally… disconnect all peripherals you can… floppy,hard drives etc etc. If you have an ammeter, place it inline to the power supply. I use this to see if the powersupply is tripping out as the current consumption spikes as the PSU tries to start the system. Some systems enforce a HARD START if you hold the power button down for 30 seconds or more

note - Either an analog ammeter or a digital one that has a fast response time - perhaps a low ohm high wattage shunt resistor with a scope attached.

#8

Hi, good morning! I have tried yesterday without any lucky, as I have promised some comments ago I have taken some pictures of the problematic laptop. On these pictures we can see the main board with their connectors, the power supply board and the logic board. I have tried replacing some suspicious capacitors, I have tested a lot of fuses too without any lucky. I have tried power the line that is connected to the batteries but I did’t have receive any response, the reles are powered but nothing change. Sadly I haven’t been able to find any schematics or service manual to this laptop model.

1 Like
#9

Is there any bulging or leakage around the electrolytics?

1 Like
#10

Nope, it was my first attempt but I have seen the board clean, without any signal of corrosion from any leaking of the capacitors or the batteries. It’s really strange, at some point a bit of corrosion or a leak can be a clue to detect the origin of the problem, but I haven’t obtained any clear clue yet.

#11

There do seem to be patches of solder which are brown instead of silver. Anything which isn’t shiny and silver - if it’s dull, or brown - might indicate a failed component, or at least a need for a scrub with alcohol.

1 Like
#12

Looks good visually … but remember that capacitors can leak around the legs too… not just the vent side. (bulging is 100% indicator, but when capacitors are temperature cycles alot, they just dry out the resistance comes down)

Observations - IPA spray and a soft toothbrush to clean inside the connectors…and the opposite side too.

1592PS board : CN2 looks like there is a bit of something in it on the edges. (may be the pictures)snippet

What are the white marks there?

1 Like
#13

These capacitors (and some other ones) have a kind of glue like gum, to limit their movement due vibrations. Anyways I will double check the zone, taking in count your observation and the comment of @EdS. :slight_smile:

#14

Hi everyone! Thanks very much for your support and helpful comments, them have inspired me a lot, but I have reach a moment to day good bye to the computer. I have replaced a lot of capacitors, checked a lot of times different connections without any lucky. I’m suspecting of the IC of the power board, sadly I haven’t been able to found any information about them.
I will freeze the repair until get any new idea or documentation that could provide a light of hope.

Again, thanks very much :slight_smile:

#15

I have to admit that I agree with you… I tried looking for the IC part number and its so obscure not even google knows about it. As with all, you win some, you lose some :smiley: Its all a learning experience.

Its now documented and good pictures - others can now stumble by and enjoy the images and journey.