"Can't read superblock" error with 5.25/360K floppy drives

Hi all.

I found a bunch of old 5.25 disks in a drawer, and I’d like to have a look at their contents and save whatever could be worth to into some other storage.

I managed to find a pair of very old 5.25 360K drives, I cleaned them up and then I removed the 3.5 drive from my oldest PC (a 2004 Pentium based system) and replaced it with one of the two 5.25 drives.

Unfortunately, the BIOS options for the single A floppy drive do not include the 5.25/360K combo; the options are 5.25/1.2M, 3.5/720K, 3.5/1.44M and 3.5/2.88M.

I tried nonetheless with both WinXP and Linux, using 5.25/1.2M and 3.5/720K options, but all my attemps failed: WinXP does not see drive A at all, while with Linux the /dev/fd0 device seems to react as expected to the issued commands, but it always reports a “can’t read superblock” error.

Since I tested a dozen different disks having constantly the same error, I fear that the issue is due to the missing option in the BIOS; if this is the case, I assume there’s nothing I can do but find a 5.25/1.2M drive OR an even older PC whose BIOS supports 5.25/360K drives.

I’d like to have my analysis confirmed or proved wrong with suggestions about how to read those disks with the hardware at hand.

Thanks in advance to anybody who can help me!

1 Like

I don’t think the computer actually knows whether it’s hooked to a 1.2 MB or a 360 KB floppy disk drive; electrically they look the same, the signals to/from the head are simply different for the different formats. I would expect (but I may be missing something) that your 360 KB drive on a 1.2 MB-configured controller would work, but be unable to read/write 1.2 MB disks (as the head is too wide).

The OS does have to know that it’s reading DD disks, however, and configure the controller for the correct encodings and modulation. In Linux this is done using the setfdprm command from the fdutils package. I don’t know how to do it (or if it can be done) in XP.

My first question for you is do you know that the floppies are 360 KB FAT-formatted? That is the only format that you would be likely to have any luck mounting directly on either XP or Linux. 5.25" floppy disks were used in a wide variety of systems, however, many of which are not directly readable by Windows or Linux and some of which may not be truly readable by a PC or a standard PC floppy drive at all. It may be that you’re reading the flux just fine, and the OS just doesn’t know what to do with it!

I suggest trying Dave Dunfield’s ImageDisk under FreeDOS. If nothing else, the drive test programs there will let you know if the controller can actually work with the drives that you’re using. It can also help you set the drive speed (which may be off due to hard or stretched belts, changed component values, etc.). In the event that the floppies are not FAT12 or not PC disks, the images will be easier to work with to identify what is actually on the floppies.

2 Likes

Hi elb, thank you very much for your inputs!

I’m pretty much sure that those floppies are 360KB FAT formatted and have been used on a PC system, even though 3-4 of them have a suspicious “420KB” handwritten on their labels, which makes me think they could have a non-standard formatting.

I will investigate both Linux setfdprm and Dave Dunfield’s ImageDisk (this will require me to setup a FreeDOS boot somehow). I’ll get back with the outcomes in a while.

FreeDOS has a LiveCD, and ImageDisk fits on a single floppy, if that helps. :slight_smile:

Some other differences: 1.2M drives rotate at two different speeds depending on whether it is in 1.2M or 360K modes, and it has a signal to tell the computer when the door has been opened. The dual speed thing was used in early PC AT computers but I think it was replaced by using different clocks in the disk controller with the drive always at the same speed.

IBM actually patented a drive type detection algorithm where it moved the head to track 50 and then moved the head inwards 49 tracks. If it was back at track 0 then this is a 360K drive but if not (if it is still at track 1) then it is a 1.2M drive. Through the 1990s IBM used this and 6 other patents to get chipset makers and PC makers to pay royalties and license other patents that would take longer to expire.

2 Likes

Ok so I tried with FreeDOS booting from the LiveCD. In this way, I can address the physical 5.25 drive on letter A:, but I always get a “Seek error” when trying to access to a disk by executing the command “dir a:”. This seems very similar to the “Can’t read superblock” error I get from Linux.

Then I tried with the TESTCFG program, with no better luck: if I run TESTCFG A:, I get a “BIOS reports no drive” error. If I try to force the drive type with TESTCFT A: 360, I get a “No FDC interrupt!” error. ImageDisk itself does not go any better.

I’ve googled for the “No FDC interrupt!” error, but I found little and nothing useful, at least in my eyes. Upon some oblique hints, I also tried to play with the drive jumpers, but I got nowhere nearer to my goal.

At this point I’m basically stuck and unable to read those disks with the available hardware. There are just too many combinations to pursue a brute force approach, and I’ve no technical knowledge to prune the tree of the “obsiously” silly attempts.

In the hope someone could still provide me with additional hints, I’m posting here all the information I’ve found about the involved hardware.

Floppy Disk Controller: NEC 765
Floppy Disk Drive: Panasonic/Matsushita JU-455-5 (360KB)

VGACOPY reports the first (and unique) drive to be on $3F0, as I assume it is expected.

Jumpers of the drive are set as the manufacturer default, except for the RY (PC XT-AT compatibility), which is set to ON, and TM (terminator) which is set to OFF; documentation is here http://www.bitsavers.org/pdf/panasonic/floppy/Panasonic_5.25-jumpers.pdf and also here

It is worth noting that:

  • I’m not sure the drive does work (even if they react to issued commands)
  • I’m not sure the disks do work (but I have no other surely working drive to test them)
  • I removed the drive from a venerable Olivetti M19, gave them a cleanup and mounted them (one at a time, of course, and changing the jumpers on the original secondary one). I had also to pick the original drive cable, since the connector on the motherboard is the same, but those drives have a flat connector; so it is possible that the cable is broken or simply not compatible with the controller.
  • I’ve found a long thread about an issue that seems very similar to mine; from the thread summary (Panasonic ju455 FDD - Vintage Computer Forum) it seems like a change in the hardware is in order, which is beyond my limits.

Any further help is appreciated.

1 Like

Marc Verdiell (CuriousMarc) has a YouTube video on accessing a 5 1/2 foppy via DOS low level tools. Maybe this can provide some inspiration?

Video (part 2 of a series of 3): https://www.youtube.com/watch?v=ANym0BgT_IE

Part 1 is about hardware connection: 5.25" Floppy Part 1: Drive Installation - YouTube
Part 2 about low level tools: 5.25" Floppy Part 2: (very) low level DOS Floppy utilities tutorial - YouTube
and Part 3 about using these tools for formating with correct sector marks: 5 25" Floppy Part 3: Recreating a HP LIF (not PC compatible) Vintage Diskette - YouTube

1 Like

Hello NoLand, thanks for your help.

Unfortunately, I came to the conclusion that my hardware is indeed suffering of the same physical problem reported in Panasonic ju455 FDD - Vintage Computer Forum, so there’s nothing much even a low level software tool can do.

I’m going to look for a different 5.25 drive which is compatible with my old PC.

Good luck!

Considering, what random parts prominet YoutTubers receive in their mail, maybe someone here has a fitting spare part?